登录站点

用户名

密码

3G原理篇(五)

热4已有 175 次阅读  2010-03-17 09:03   标签:  原理 

3、TxAA 发射分集

图5-3  闭环反馈发射分集

TxAA闭环反馈发射分集对于下行链路性能提高为1-2dB左右。模式1是通过调整相位、模式2是通过调整相位和幅度。模式1的应用场合主要是低速移动或分集天线路径之间有相关的衰落信道,而模式2的应用场合可以保证两个分集天线通道之间的功率平衡。

该分集方式对于UE的RAKE接收机的复杂度增加18%。TxAA闭环反馈发射分集对于基站侧而言作为可选项,对于UE侧而言,如果是低档终端(low cost terminals.)为可选项,如果是高档终端(high-end terminals )为必选项。

 

4、各种发射分集适用信道

Physical channel type

Open loop mode

Closed loop

 

TSTD

STTD

Mode

P-CCPCH

不支持

支持

不支持

SCH

支持

不支持

不支持

S-CCPCH

不支持

支持

不支持

DPCH

不支持

支持

支持

PICH

不支持

支持

不支持

PDSCH

不支持

支持

支持

AICH

不支持

支持

不支持

 

5、发射分集的好处是非常明显的,对网络侧的影响最大的是NodeB,主要是射频部分的发射通道需要两路。在不同的覆盖场景下,可获得0~2dB的额外增益,最大可增加26%覆盖面积或者58%无线容量。系统对发射分集模式的配置控制最主要的是根据不同无线信道环境来配置,从而实现最佳性能。

1.   什么是高速下行分组接入技术(HSDPA)?

答复:

高速下行分组接入(High Speed Downlink Packet Access,HSDPA)是3GPP在Rel5协议中为了满足上下行数据业务不对称的需求提出来的,它可以使最高下行数据速率达10Mbps,从而大大提高用户下行数据业务速率,而且不改变已经建设的WCDMA系统的网络结构。因此,该技术是WCDMA网络建设后期提高下行容量和数据业务速率的一种重要技术。

HSDPA采用的关键技术为自适应调制编码(AMC)和混合自动重复(HARQ)。AMC自适应调制和编码方式是根据信道的质量情况,选择最合适的调制和编码方式。信道编码采用R99 1/3Turbo码以及通过相应码率匹配后产生的其它速率的Turbo码,调制方式可选择QPSK、8PSK、16QAM等。通过编码和调制方式的组合,产生不同的传输速率。而H-ARQ基于信道条件提供精确的编码速率调节,可自动适应瞬时信道条件,且对延迟和误差不敏感。

为了更快地调整参数以适应变化迅速的无线信道,HSDPA与WCDMA基本技术不同的是将RRM的部分实体如快速分组调度等放在Node B中实现,而不是将所有的RRM都放在RNC中实现。

2.   智能天线波束宽度是多大? 多径条件下如何跟踪用户?

答复:

智能天线波束的宽度和天线的个数相关,天线越多,beam width越小,而且beam width跟天线阵的具体排列也有关系,不能一概而论。一般四元阵的beam width约二十度。

在多径条件下跟踪用户,要求算法响应速度较快,能实时覆盖所有的路径,华为公司的算法可以实现所有路径的跟踪。

3.   GGSN和SGSN是否和GPRS中的设备相同?

答复:

从组网的作用上看是相同的。但在WCDMA系统中实现的协议已经和GPRS不同了。而且在3G系统中,用户较之GPRS的带宽需求和业务需求也增加了,对于SGSN、GGSN的需求也提高了。WCDMA R99版本要求实现的QoS的能力较之GPRS R98版本提高,要求实现区别服务的能力。

当前GPRS网络中的SGSN和GGSN不能满足3G要求,但可以通过平滑升级(硬件和软件)GPRS到3G,华为公司3G中的SGSN设备可以同时提供GPRS/UMTS用户的接入,支持系统间漫游和切换,从而实现2.5G、3G的平滑过渡。

4.   3G电路域和分组域网络鉴权和认证基本要求

答复:

3GPP使用鉴权5元组,除支持网络鉴权UE外,还增加了UE鉴权网络的功能。通过分配临时用户身份标识(电路域TMSI,分组域P-TMSI),减少在空口使用IMSI,增强用户身份的隐秘性。MSC/SGSN一次从HLR提取多组鉴权集,提供鉴权集重用功能,以减少D接口和Gr接口的信令流量。

3GPP加密功能由CN控制,在RNC和UE之间进行。

5.   2G系统和3G系统中对用户的鉴权有哪些区别?

答复:

在2G系统中,根据系统配置,当用户终端进行开机登记、切换等操作时,网络设备可以通过对鉴权3元参数组(RAND、SRES、Kc)进行一系列的操作来对用户终端的身份进行识别,此过程称为鉴权。如鉴权成功,则用户可以进行相关操作,否则操作将被禁止。

在3G系统中,除了网络设备可以对用户终端的身份进行识别外,还增加了用户终端对网络设备的身份进行识别的功能,即网络和用户终端之间的双向鉴权,这将通过对鉴权5元参数组(RAND/XRES/CK/ IK /AUTN)进行一系列的操作来实现。

由于2G系统中的鉴权机制是单方面的,即只考虑了网络对用户的认证,而没有考虑用户对网络的识别。由此带来的问题是,可以通过伪装成网络成员对用户进行攻击。3G系统克服了这种安全隐患,并考虑了安全的扩展性。

6.   相对2G系统,3G在信息安全措施上有哪些改进?

答复:

2G系统的加密机制是针对空中接口的,只有在无线接入部分的信息被加密,而在网络内的传输链路和网间链路上的信息仍然使用明文传送。2G中使用的加密密钥长度是64 bit,现在已经能在较短的时间内解密该密钥。在2G中没有考虑密钥算法的扩展性,只采用了一种加密算法,致使更换密钥算法十分困难。另外2G系统的信息传送没有考虑消息的完整性。

与2G系统相比,3G系统不仅加长了密钥长度,而且引入了加密算法协商机制。3G系统加强了消息在网络内的传送安全,采用了以交换设备为核心的安全机制,加密链路延伸到交换设备,并提供基于端到端的全网范围内的加密。在3G系统中采用了消息认证来保护用户和网络间的信令消息没有被篡改,保护了消息的完整性。

7.   七号信令传输如何变为MPLS,也就是如何用IP承载?

答复:

七号信令在IP网上的传送 ,华为公司已经有 SG 产品来实现 。 只需要在IP协议上迭加 SCTP/M3UA 协议 , 就可以实现对SCCP 协议的支持 。

SCCP

M3UA

SCTP

IP

8.   R4如何和PSTN网络互通?

答复:

R4系统通过TDM接口与PSTN网络互通,互通的方式为:MSC Server通过 ISUP与PSTN实现信令互通;MGW通过G.711/TDM话音(64kbs)与PSTN实现承载的互通。具体实现时,其中一种方案是:ISUP信令在MGW与PSTN的局间中继上传送,通过MGW的SIGTRAN功能转换后,经IP网传送到MSC SERVER。

9.   路由器支持哪些安全协议,启用后对路由器的性能影响?

答复:

IPSec

 

 

报文封装(tunnel、transport)

 

安全协议esp(RFC2406)、ah(RFC2402)、ah-esp(RFC2401/2402/2406)

 

加密算法(3des、des、blowfish、cast、skipjack)

 

ESP验证算法(md5-hmac-96、sha1-hmac-96)(RFC2403)

 

AH验证算法(md5-hmac-96、sha1-hmac-96)(RFC2403)

 

手工配置安全联盟

 

IKE自动协商安全联盟

 

访问列表支持

 

安全策略

 

支援数据流分类

IKE(RFC2409)

 

 

安全策略

 

身份验证字(pre-shared key)

 

安全策略支持56-bit DES-CBC加密算法

 

安全策略支持168-bit 3DES-CBC加密算法

 

安全策略支持MD5散列算法和SHA-1散列算法

 

安全策略支持使用Diffie-Hellman交换生成密钥

 

支持使用keepalive握手报文

加密卡

 

 

安全协议(esp、ah、ah-esp)

 

加密算法(3des、des、blowfish、cast、skipjack、aes、skipjack、qc5)

 

ESP验证算法(md5-hmac-96、sha1-hmac-96)

 

AH验证算法(md5-hmac-96、sha1-hmac-96)

 

AAA, RADUIS

Fire Wall

NAT(RFC1631)

安全算法启动对路由器有一定影响,不同的算法影响程度不同。

10.            移动网络中信令寻址方式有哪些?各有什么优缺点?

答复:

移动网络中信令寻址方式有两种:DPC+SSN;GT+SSN。DPC是目的地信令点编码,GT是全局码(Global title),SSN是子系统号(用于区别MSC/VLR、HLR等)。采用DPC+SSN方式的优点是使用DPC直接在七号信令网中寻址,消息传递时延短;缺点是需要定义全网与它有SCCP信令关系的信令点的点码,局数据量大,维护和管理不方便。采用GT+SSN方式的优点是只需定义SCCP转接节点的信令点点码(如LSTP的SP),消息首先传送给SCCP转接节点,由SCCP转接节点传送到目的地;缺点是每经过一次SCCP转接节点就增加时延。在实际工作中,通常是两种寻址方式都会使用。

11.            什么是APN?

答复:

APN是Access Point Name的缩写,称为接入点名称,由网络标识和运营者标识两部分组成,网络标识定义了GGSN所要连接的外部网络。运营者标识是可选的,定义了GGSN所在的PLMN GPRS分组网。SGSN通过 APN解析找到所要用的GGSN。另外,在GGSN内APN可以用于识别外部数据网。

12.            什么是SIGTRAN?

答复:

SIGTRAN是Signalling Transport的缩写,是电话信令消息在IP网络上传送的适配协议的总称。SIGTRAN协议栈结构示意图如下:

BICC、ISUP、TUP、RANAP、MAP、CAP、INAP、SCCP

M3UA、M2UA、IUA、SUA、M2PA、V5UA、DUA

SCTP

IPV4/IPV6

信令适配层对电话信令消息进行适配,保证电话信令消息可以未经修改地传送,如M3UA是BICC、ISUP、SCCP的适配层,M2UA是MTP3的适配层。通过使用SCTP(流控制传输协议)保证在IP网上提供可靠的消息包传输。

 

13.            什么是TFO、TrFO,各有什么优点?

答复:

TFO是Tandem Free Operation 的缩写,是在呼叫建立后通过两个TC(编解码器)对所使用的Codec进行带内协商完成,使得移动用户之间的呼叫可以避免在发端和收端侧进行不必要的语音编解码转换,从而提高话音质量。虽然不需要TC进行编解码转换,但TC要一直监视进行中的呼叫,所以TFO并不节省TC资源。TFO在GSM、R99都有应用。

TrFO是 Transcoder Free Operation的缩写,是一种带外的协商机制,可通过MSC SERVER之间的信令进行协商,使得网络可以在呼叫建立前就对Codec的类型和模式进行协商,经协商后,移动用户之间的呼叫可以完全不经过编解码器,从而提高话音质量。因为采用的是带外的协商机制,所以TrFO不需要TC资源,从而节省了昂贵的TC资源及其带来的功耗。TrFO的另一好处是分组承载中使用时可以节省网络带宽,因为话音可以以AMR 12.2 kbps的速率在核心网中传输。TrFO是使用ATM或IP承载的R4网络特有的技术。

14.            R4的承载方式有哪些及其各自优缺点?

答复:

在3GPP的规范,R4承载方式只对ATM和IP进行了定义。但目前也有不少厂家是支持TDM、ATM和IP三种承载方式。

TDM承载方式的优点:话音质量好;网络安全有保证。缺点:信令和话路都需要分级汇接;对带宽资源的利用率低;不符合网络IP化的趋势。

ATM承载方式的优点:服务质量有保证;可采用TrFO技术,具有统计复用的优势,带宽资源的利用率高;网络安全有保证。缺点:信令和话路都需要分级汇接;目前ATM网络不如TDM网络和IP网络成熟;网络管理比较复杂。

IP承载方式的优点:可采用TrFO技术,具有统计复用的优势,带宽资源的利用率高;话路不需要分级汇接;IP承载是网络发展的趋势。缺点:缺少大规模的商用经验。

15.            3G用户是如何访问外部数据网的?

答复:

3G用户访问外部数据网之前,必须先通过了HLR/AuC的身份认证和鉴权流程成功附着到SGSN。然后,MS发起PDP上下文激活过程,相关的信令带了APN参数,SGSN通过DNS解析APN,获取GGSN的IP地址,然后向GGSN发起创建PDP上下文过程并进行QoS参数协商,GGSN返回的成功响应中会含有用户IP地址等必要信息。当PDP上下文激活后,用户就可以发送数据包,数据包在SGSN和GGSN之间是通过GTP隧道承载,到达GGSN后被转换成普通IP包,进入外部数据网(通常指的就是Internet)。

漫游用户可以通过拜访地或者归属地的GGSN进入外部数据网,由运营商根据业务和路由策略决定,通常对于Internet接入业务使用拜访地GGSN,对于Intranet接入业务使用归属地GGSN。

根据鉴权方式和用户IP分配策略的不同,用户接入到外部数据网通常有两种方式:

透明接入方式:移动用户的IP地址由GGSN分配,移动用户在激活PDP context时不需要进行第二次鉴权。

非透明接入方式:移动用户的IP地址由外部数据网的DHCP服务器或RADIUS服务器分配。移动用户在激活PDP context时还需要进行一次身份认证和鉴权,此时GGSN起AAA客户端作用。

一般来说,对于Internet接入业务采用透明接入方式,方便用户快速接入;对于Intranet接入业务采用非透明方式,执行企业网内部的安全策略。

16.            MIP技术简单介绍,及技术实现方案

答复:

简单来说,MIP技术的目的就是移动节点(不限于手机)在不改变IP地址的情况下可以从一个子网移动到其他子网。一个移动节点通常由它的“Home IP address”来设定其地址,这个地址是在“Home subnetwork”上分配给移动节点的,此地址的子网前缀是“Home subnetwork”的子网前缀。使用“Home IP address”发送到移动节点的数据包,首先到达HA(HOme Agent),查找移动节点的注册信息,获得用户当前所在子网的FA(Foreign Agent)地址,然后访问FA,从而最终找到移动节点,继续保持通信。由于移动节点的“Home IP address”保持不变,所以它的移动对于传输层和更高层来说是透明的。

 

MIP不是专门针对蜂窝移动通信系统设计的技术。附件的原理图应该是基于MIPv4的,故上述描述也是针对MIPv4。MIPv6的实现有所不同。实现MIPv4特性需要GGSN支持FA功能。

1.   频间硬切换实现的机制,以及对RNC性能的影响

答复:

频间硬切换包括异频同覆盖小区之间的异频小区负载平衡所引起的频间硬切换和异频相邻小区由于覆盖范围和UE的移动性所引起的频间硬切换。华为公司WCDMA设备对这两种方式均支持。

频间硬切换的两种方式适用于不同的情形并可以相互补充。在网络规划的时候,在话务量比较大的密集城区,建议配置异频同覆盖小区,这样就会触发异频小区负载平衡所引起的频间硬切换的方式;在话务量较少的地区,由于小区分布一般不会重叠,因此如果没有同频相邻小区,只能采用异频相邻小区由于覆盖范围和UE的移动性所引起的频间硬切换方式。

对于异频同覆盖小区之间的异频小区负载平衡所引起的频间硬切换,负载控制的判决算法会占用一部分RNC的CPU资源,但由于测量报告的获得是与准入控制共用的,因此不占用附加的资源,仅仅需要算法判决的系统资源,而这部分资源在整个系统资源中所占比例很少。华为公司提供的设计规格中,RNC的处理能力已经包括了这部分开销。

对于异频相邻小区由于覆盖范围和UE的移动性所引起的频间硬切换,需要启动压缩模式进行测量和判决,也需要占用一定的系统资源,这些开销也已经计入产品设计规格中,RNC现在的处理能力已经包括了这部分开销。

2.   RNC IuCS和IuPS能否通过同一物理链路到MSC再到SGSN

答复:

可以,前提是MSC支持ATM解复用。也就是RNC将Iu-PS和Iu-CS映射到不同的PVC然后复用到同一条光纤,MSC通过解复用将Iu-PS数据/信令中继到SGSN。如果RNC与核心机房距离很远,使用这种方式可以节省传输资源。

3.   分组域设备IP地址如何规划

答复:

1、以下IP地址需求,包括SGSN,GGSN,CG,DNS。四个IP地址段:

l         2个用于网络管理,私有 IP 地址;

l         4个用于SGSN  Gn/Gp,5 个用于GGSN Gn/Gp,2个用于DNS,一般提供一些地址保留使用,可以是私有IP 地址, 或者是公有IP 地址,但一般使用公有IP地址;

l         4个用于SGSN Ga,2 个用于GGSN Ga,2个用于CG,私有IP 地址;

l         2个用于GGSN Gi,公有IP 地址。

 

建议整个系统的IP地址划分为4个不同VLAN:

l              GSN的Gn/Gp接口在一个VLAN当中

l              Gi接口使用一个VLAN

l              Ga接口与计费系统位于一个VLAN

l              OMC位于一个VLAN

 
分享 举报

发表评论 评论 (2 个评论)

涂鸦板